Hakchi Resources! The one stop shop for the latest releases, mods, guides and resources for everything Hakchi.
Hakchi2 CE ‘Community Edition’ v3.4.1 – Hakchi Resources

Hakchi2 CE ‘Community Edition’ v3.4.1

August 6, 2018 | By Team Shinkansen | Filed in: Hakchi Application Tool.

35880808.png

This is v3.4.1 of hakchi2 CE. This release should be ready to handle the new 2018 models of Nintendo NES/SNES minis (NES 2018 rerelease and Shounen Jump special edition Famicom). It also incorporates a more stable and versatile network discovery mode, mDNS, which is, incidentally, the main reason for another important version jump.

Changelog

  • Fix command lines of Shounen Jump original games
  • Remove obsolete now unused console settings Enable USB host and Use extended font
  • Update Font Remount hmod, including a new font with more characters
  • Add /info user directory where one can add libretro .info files for custom cores
  • Fix a bug that prevented readmes from appearing correctly in Select modules form
  • Update hakchi.hmod core scripts:
    • mDNS announce service
    • flash uboot should work fine now
  • Fix games not checking in some games collections when adding games and Separate games storage is disabled
  • Fix export games on Shounen Jump silently failing
  • Add some safeguards on Tools -> Switch running firmware
  • Add some amazing user submitted (on Discord server) folder images
  • Reworked the internals handling NES/SNES mini detection on the network, hopefully for the best
  • Removed PING listener; add DNS resolve listener
  • Longer timeouts in MemoryStats.cs to allow for very large game collections
  • Fix firmware switching causing issues over wifi
  • Removed blacklisted hmods from user_mods

  • Memboots (kernel and modules operations) will always use up-to-date boot.img now.

  • Improvements to flashing/uninstall messages.
  • Added MD5 of new 2017 re-released NES mini and Shounen Jump Famicom mini.
  • hakchi.hmod: Fixed some cases of MD5 checksum fail.
  • hakchi.hmod: p0000_config was being reset on hmod install/uninstall.
  • Fixed listener would get “stuck” when all ping attemps would fail.
  • Fixed window icon of WaitingForShellCycleForm.
  • Fixed SSH listener would not release resources properly on ping fails.
  • Fixed out of bounds number on size indicator.
  • Savestate manager: should not erase non-standard save folders anymore (used by retroarch for instance).
  • Savestate manager: Increased timeout values.
  • Core selecter: clicking Show all for systems should update core list accordingly.
  • Linked export/linked sync would rename CLV-* names to uppercase and this caused issues with .desktop links.
  • New games added were not checked by default in other games collections.
  • Game Genie: clicking on + when the text box is empty should not cause an exception anymore.
  • Internal changes to libraries.
    • SharpCompress + tiny7z instead of 7z.dll.
    • LibUsbDotNet from official source instead of copied wholesale.
    • GitHub forks of ProgressODoom instead of copied wholesale.
  • Added Shounen Jump games list.
  • Kernel flashing should now work properly on Shounen Jump systems (no ramdisk).
  • Show in explorer and Delete options are added to Modules selector.
  • Allow reinstalling modules.
  • Games cache doesn’t rely on hardcoded lists anymore.
  • New option: Always copy original games, when enabled, only cached original games are allowed, and when exporting/syncing, they are
    copied instead of linked.
  • Autoplay/pixelart folders should now be copied and linked properly on linked sync.
  • When Separate for multiboot is unchecked, user is locked into connected console type.
  • Reload games after selecting new cores in Core selector.
  • Reload games after updating original games cache.
  • Restrict alphanumerical characters in Add custom app dialog, also fixes an exception.
  • Software should function normally (not crash) even with a custom hakchi image with no original games.
  • New option: Separate local games storage, which when unchecked, stores all games in the same /games folder, instead of splitted in
    /games and /games_snes.
  • New option: Convert SNES ROMS to SFROM, allows controlling whether or not hakchi2 CE will convert added SNES games to SFROM or
    not.
  • New option: Add games as is in Files menu. This option skips file content detection on compressed games.
  • New option: Tools > Switch running firmware, allows switching currently running firmware on your NES/SNES mini.
  • Clovershell is now officially outdated. When hakchi2 CE connects to your NES/SNES mini using Clovershell protocol, emulated FTP and
    synchronization are disabled.
  • Increased waiting period when rebooting.
  • Fix uboot flashing.
  • Prevent reloading recovery image when already in recovery mode.
  • Internal changes to allow compiling on Mono (still not 100% functioning, but compiles).
  • Add German translation.
  • Modstore: fix refresh functionality.
  • Modstore: add alphabetical sorting.
  • Add Rock’n’roll Racing and Tetris & Dr.Mario ips patches.
  • Update to libretro *.info files, using TheOtherGuys official Retroarch repository.

Hakchi2 CE ‘Community Edition’ v3.4.1 Download Link


13 comments on “Hakchi2 CE ‘Community Edition’ v3.4.1

  1. Anubus says:

    I was wondering. Why such a big version jump from v1.2.5?

    • TarkinMX says:

      As was mentioned on the subreddit, the version number was changed to reflect the internal version number so that people will hopefully stop getting confused with thinking that Cluster’s version was newer.

    • Internally, we were at 3.2.5, but we displayed it as 1.2.5.

      The jump is because we just removed the code to subtract 2 and just display it as it is.

  2. Samantha says:

    I’m having an issue with v3.4.1 , it seems like mu NES Mini only loads the games from USB every OTHER time i start it up.

    i’ll turn it on, see all the added games and my custom folder menu, turn it on and on again and it’s back to it’s stock 30 game menu. shut it off and on again and the custom menu and games are back.

    is any one else having this isssue or know how it can be resolved?

    thanks!

  3. Decanfrost says:

    I have newest CE build installed. V3.4.1 decided to make a new ad card from scratch everything went well except no games load anymore went to retroarch load screen and then ba k to game menu.. I tested with my other ad card that had been working since v1.2.5 and it’s fine. It seems that when i install the hoods they are not transferring to the sd card even after installing the external reteoatch hmod

  4. Ashley says:

    Hello, I keep getting an error message about the the given key not being present after a opening Hakchi a few times?

  5. Kyle says:

    when go to the kernal and hit install/repair i get an install error the inf file you selected does not support this method of installation. First time using this hakchi i dont know what im doing wrong

  6. Alex says:

    For some reason I can only add 2 games to the NES. Under the Add Games it only shows 2 and when I add more if just replaces those, leaving still only 2 games.

  7. DarthBreh says:

    Same problem as before when trying to flash NES or SNES it hangs at waiting for console to reboot and never does so it wont flash anything 2018 versions

  8. Aacelius says:

    Portable MODE
    Local hakchi.hmod version info: boot 1.0.2, kernel 3.4.113.23-madmonkey, script v1.0.4-120

    When I try to “ADD GAMES” the progress bar gets hung up at 70.9/81% and just stalls. It says in the DOS prompt that all games were successful… yet… I can then continue to add box art. I dont know whats going on.

  9. Brandon says:

    I just got a the NES classic and I’m trying to add games. They’re on the menu, but when I click on them they go to a loading screen then back to the main menu. Originals all work fine, it just when I add any?

  10. Russ says:

    I’m using Hakchi CE 3.4.1. I keep receiving a blue-screen system error every time I try to upload games to my SNES Classic Mini.

    “DRIVER_IRQL_NOT_LESS_OR_EQUAL”

    Never happened with other versions of Hakchi, but happens every time now and makes my PC crash. 🙁

  11. exile090 says:

    I tried to install/repair the kernal but it says, ” The INF file you selected does not support this method of installation.”