Hakchi Resources! The one stop shop for the latest releases, mods, guides and resources for everything Hakchi.
Hakchi2 CE ‘Community Edition’ v3.5.0 – Hakchi Resources

Hakchi2 CE ‘Community Edition’ v3.5.0

October 22, 2018 | By Team Sinkansen | Filed in: Hakchi Application Tool.

RA.png

It’s been a while, but hakchi2 ce 3.5.0 is finally here!

This release brings a bunch of fixes and new features, one of the most notable being the mod hub, a repository system that allows sources other than the mod store to be easily accessed from CE.

The first repository to make use of this new feature is KMFD’s Mod Hub, so no more downloading the hmods manually from the pack just to get one of them that were updated.

Other notable changes is that the PuTTYtel telnet client is included and the Open FTP Client menu item now opens windows explorer by default.

Also included is preliminary support for running in mono on Linux, to run without crashing, ensure you have libusb installed.

Hakchi2 CE ‘Community Edition’ v3.5.0 Download Link


13 comments on “Hakchi2 CE ‘Community Edition’ v3.5.0

  1. James Brown says:

    Hi there, thanks a lot for releasing this new version! You guys rock. One question, if you don’t mind. Since the improvement are mostly for pros, for the rest of us mere peasants, would you say this is somehow a stability update? Like bug fixes and so. Thank you once again!

  2. Ashley says:

    I downloaded the Hakschi application, flashed my NES okay, but I’m confused as to how to add the games? where do they come from? do I need to download them from somewhere?

  3. Gonza92 says:

    Hello I have a question, it is normal that the snes mini U.S.A edition overheating? Thank you.

  4. John says:

    really?.. i now have to restart my pc after install the snes driver? windows 7 32bits

  5. N says:

    I just installed the latest version and I’m not being prompted to install the drivers. And every time I try to install a module or flash kernel it gets stuck in a load screen limbo.

  6. bobey49 says:

    I currently running hackchi2 CE 3.4.1 do I have to install all the game again and reflash the nes classic if I upgrade to hakchi2 CE 3.5.0 because I know the program will automatically updates but haven’t run windows on my MacBook Pro in a while just don’t want it to be a surprise disappointment
    And would be nice to have Mac OS support on feature update

    • DNA64 says:

      No, you do not need to install all the games again when upgrading (And the software has no effect on the system unless you sync). That said, I personally recommend that everyone make a backup of their Hakchi 2 CE folders BEFORE updating. You should ALWAYS make a backup. I usually just compress my folder into a zip file. This way in the event anything goes wrong, or you make a mistake, you’ll always have that old build you can go back to.

  7. Charlie says:

    Hi I recently bought a UK edition nes but am having real problems as none of the game a I have flashes onto the nes mini work. The artwork and folders are fine as are the original games.As I was only playing nes games I don’t need to download the retroarch emulator do I? the games that don’t work are in .zip format. From tutorials I’ve seen the command line doesn’t necessarily get changed on each game.Any help would be appreciated

    • DNA64 says:

      When flashing .nes games to a .nes classic using Hakchi 2 CE, make sure the ROMs are NOT PAL (EU) versions, as unless you’ve installed RetroArch and a compatible CORE like FCEUmm they will not work as the system uses North American NTSC ROMs. If you still have issues, chances are the ROM itself is BAD, find a new source and make sure the new file has a different checksum.